Good day, I had and old PC system which I decided to upgrade, I swapped half of my old components for a new line of ryzen 2600 CPU. I bought Ryzen 2600, ASRock AB350M PRO4 motherboard which had "Ryzen 2000 series ready" sticker on it and 1 stick of G.Skill 8GB 3200Mhz RAM.
My system looks like that:
700W PSU
GTX 660 3Gb
ASRock AB350M PRO4
Ryzen 2600 with stock Wraith Stealth on top
G.SKILL RipJawsV Series Black 8GB 3200MHz CL16 DDR4 F4-3200C16S-8GVKB20First I decided to put all the parts and boot my old windows, it worked perfectly until it froze after 20 minutes, after that it didn't work even for 5 minutes after booting. I started digging what could be the problem, is it motherboard, maybe RAM? I don't have any other DDR4 Ram so all I could is to try other RAM slots. Reinstalled windows, didn't help, system freezes after few minutes of using it. Then I started checking bios and to my surprise this motherboard ran only 3.0 version of BIOS, Ryzen 2600 requires minimum 4.7 bios version. So I thought maybe that's it, maybe all my problems are from ignorance of motherboard manufacturers. I flashed bios to 3.4 bridge, then I flashed it to 4.9. Now in bios settings it clearly shows that version is 4.9, but that didn't achieve anything...system still freezes after few minutes of using. By default RAM voltage is 1.35v but speed is set up at 2133Mhz, tried to raise it to 3200 with 1.35v, nothing changed.
I will appreciate any help.