Hey there guys,

I have just recently bought x3 Cisco 2504 routers for use in a mini lab that I built at home to help prepare for my CCNA exam. I found that all 3 of my routers are running IOS version 10.8, which is ancient and I would like to run a later/latest version IOS but found that the 2504 router is no longer supported by Cisco.

So where am I able to obtain new IOS's now? I plan to use these routers for educational purposes so am I still expected to spend BIG $$$$ on licensing?

PS:
I also have a Cisco 827-4v router, which is running IOS version 12.1 and I am thinking to run version 12.3, are you guys able to help or point me in the right direction?

Thank you...