Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Need Help Troubleshooting Wake on Lan (WOL)




  1. #1
    adrien.hy.lee is offline Junior Member
    Join Date
    Oct 2012
    Location
    Toronto
    Posts
    2

    Smile [Solved] Need Help Troubleshooting Wake on Lan (WOL)

    Hi All,

    It appears that I am in need of aid to implement Wake on Lan successfully. I can't seem to figure out the problem.
    I have followed through a few tutorials online and tried to Google for the issue (somewhat) extensively.
    I appreciate your help in advance.
    __________________________________________________ __________________________________________________ _____________
    The Problem:
    Using a packet sniffer (described later in the following steps), it was able to detect Magic Packets sent to my computer. However, when the computer is turned off, it does not react to these packets.

    __________________________________________________ __________________________________________________ _____________
    Steps I have taken:

    - Ethernet cable hardwired: Router connects to D-Link splitter with Ethernet cable, which is connected to my desktop's Ethernet port with Ethernet cable.

    1) Enabled WOL on Ethernet Card (on-board):
    - In Device Manager > Network adapters > Realtek PCIe GBE Family Controller > Advanced, Enabled "Wake on Magic Packet" and "Wake on pattern match", and "WOL & Shutdown Link Speed" is set to "10 Mbps First" as default (other options are "100 Mbps First" & "Not Speed Down").
    - Checked all three (1) Allow the compputer to turn off this device to save power, (2) Allow this device to wake the computer, and (3) Only allow a magic packet to wake the computer) in Device Manager > Network adapters > Realtek PCIe GBE Family Controller > Power Management

    2) Installed Windows Feature "Simple TCIPIP Services":
    - Checked Windows Features > Simple TCPIP services (i.e. echo, daytime etc), pressed Ok and it installed successfully.

    3) Started Service "Simple TCP/IP Services"
    - In Administrative Tools > Services > Simple TCp/IP Services Properties (Local Computer), set Startup Type as "Automatic"

    4) Open UDP for Port 9 in Windows Firewall
    - Windows Firewall with Advanced Security > Inbound Rules, clicked "New Rule...", Port, clicked "Next", set Protocol to "UDP", & "Specific local ports:" to 9, clicked "Next", checked "Allow the connection", clicked "Next", checked "Domain", "Private" & "Public", clicked "Next", entered name "WOL", and clicked "Finish".

    5) Forwarded the Port on Router
    - Logged into router > Forwarded Port 9 to LAN IP (with Protocol set to "Both" (UDP & TCP)

    6) Tested Whether Magic Packets were Received from Third-Party Applications
    For the points below, I used my External IP (WAN IP) starting with 174.112... and router hex MAC IP.
    - Tried both tools to send packages: the website Wake-On-LAN Online (WOL) - Wake up your computer over Internet, no software needed! and "Wol Wake on Lan Wan" by Brobble on an Android device (https://play.google.com/<wbr>store/apps/details?id=com.<wbr>benfinnigan.wol&feature=<wbr>s earch_result#?t=<wbr>W251bGwsMSwyLDEsImNvbS5iZW5ma W<wbr>5uaWdhbi53b2wiXQ..)
    - Magic Packets sent from both tools were received, as observed by "Wake-on-LAN Packet sniffer" (at http://www.profshutdown.com/<wbr>download.aspx) as shown:
    Need Help Troubleshooting Wake on Lan (WOL)-1-jpg

    7) In BIOS:

    Some of the features below are as default, but I have listed them anyways in case they were supposed to matter. I have specified which ones were default.

    Integrated Peripheral
    Onboard LAN Funtion: Enabled (default)
    Onboard LAN Boot ROM: Enabled

    Power Management Setup
    - ACPI sleep state S3(STR): Enabled (default)
    - USB Wake up from S3: Enabled (default)
    - Modem Ring Resume: Enabled
    - PME Event Wake Up: Enabled
    - Power On By Mouse: Disabled (default)
    - Power On By Keyboard: Disabled (default)
    - AC Back Function: Soft-Off (default)
    - Power-On by Alarm: Disabled (default)
    - ErP Support: Disabled (Default)

    __________________________________________________ __________________________________________________ _____________
    Notes:
    - When in sleep/hibernate/shutdown state, there is no orange or green light at the Ethernet port at the back of the computer (not sure if this matters).

    __________________________________________________ __________________________________________________ _____________

    Is there anything that I might have missed?

    Again, much thanks for your help :)
    Last edited by adrien.hy.lee; 10-11-2012 at 06:13 AM.

  2. #2
    adrien.hy.lee is offline Junior Member
    Join Date
    Oct 2012
    Location
    Toronto
    Posts
    2

    Default Re: Need Help Troubleshooting Wake on Lan (WOL)

    It is working now.

    Initially, thinking that I left out something in the BIOS' settings, I contacted Gigabyte and they sent me an update of the BIOS version from F5 to F9c.

    I updated the BIOS version and made changes to the settings as before (since the update returned values to default), and it still didn't work, so it lead me to look elsewhere.

    In the end I found out that I used my router's MAC IP instead of my Ethernet's MAC IP when sending the Magic Packets. My computer receives them in either case with the packet sniffer (above) when my computer is on, but I guess it didn't reach my computer when it was powered off/sleeping.

  3. #3
    Join Date
    Sep 2015
    Location
    USA
    Posts
    1

    Default Re: Need Help Troubleshooting Wake on Lan (WOL)

    Here is an updated step by step guide for Configure WOL in Windows 10 and 8.1

    Hope it helps for somebody else who read this article.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •