Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: Java2 install problem




  1. #1
    Join Date
    Jun 2003
    Posts
    135

    Default

    LoadPlugin: failed to initialize shared library /usr/local/mozilla/plugins/java2 /plugin/i386/ns600/libjavaplugin_oji.so [libstdc++-libc6.1-1.so.2: cannot open s hared object file: No such file or directory]

    thing is, i can look right at that file, it's in the specified directory and named the same thing. all permissions are apporpriate.

    ok, installed mozilla 1.6, went fine. went about installing the plugins (from root). seemed to go fine. but when i restart mozilla the plugins seem like they're not installed and i'm asked to download them again. did i do something wrong?
    thanks in advance.
    rig changes too much
    dual boot: WinXP SP1, Mandrake 9.2

  2. #2
    Join Date
    Dec 2002
    Location
    caves of bedrock
    Posts
    3,129

    Default

    libstdc++-libc6.1-1.so.2
    where is ^ that file?
    what i can guess is that you can look at libjavaplugin_oji.so but you don't have that shared file it requires.
    you can find the rpm here...
    http://at.rpmfind.net/opsys/linux/RP...3mdk.i586.html
    Latest Microsoft Security Updates.
    Last Updated:
    10th MARCH


    If you are a security freak: Use Microsoft Baseline Security Analyzer (NT/2000/XP/2003)
    ======================
    icq : 203189004
    jabber : asklepios20@jabber.org
    =======================
    Linux user since: April 24, 2003 312478
    yabaa dabaa doo...
    Customized for 1024x768

  3. #3
    Join Date
    Jun 2003
    Posts
    135

    Default

    ok, did that. now i get this

    LoadPlugin: failed to initialize shared library /usr/local/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so [/usr/local/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so: undefined symbol: __vt_17nsGetServiceByCID]
    rig changes too much
    dual boot: WinXP SP1, Mandrake 9.2

  4. #4
    Join Date
    Dec 2002
    Location
    caves of bedrock
    Posts
    3,129

    Default

    you need to create a soft link with libjavaplugin_oji.so located in ns610-gcc32 folder and not ns600
    Latest Microsoft Security Updates.
    Last Updated:
    10th MARCH


    If you are a security freak: Use Microsoft Baseline Security Analyzer (NT/2000/XP/2003)
    ======================
    icq : 203189004
    jabber : asklepios20@jabber.org
    =======================
    Linux user since: April 24, 2003 312478
    yabaa dabaa doo...
    Customized for 1024x768

  5. #5
    Join Date
    Jun 2003
    Posts
    135

    Default

    Quote Originally Posted by asklepios
    you need to create a soft link with libjavaplugin_oji.so located in ns610-gcc32 folder and not ns600
    been using linux for less than a week. how do i do that?

    also, i have an ns4 folder and ns600, no ns610-gcc32 folder. where is it supposed to be?
    rig changes too much
    dual boot: WinXP SP1, Mandrake 9.2

  6. #6
    Join Date
    Feb 2003
    Posts
    346

    Default

    rather than copying the plugin file to your mozilla plugins directory type:
    "ln -s /path/to/libjavaplugin.so libjavaplugin.so" while in your mozilla plugins directory :cheers:

  7. #7
    Join Date
    Jun 2003
    Posts
    135

    Default

    Quote Originally Posted by theyneverknew
    rather than copying the plugin file to your mozilla plugins directory type:
    "ln -s /path/to/libjavaplugin.so libjavaplugin.so" while in your mozilla plugins directory :cheers:
    i don't have a libjavaplugin.so i do have a javaplugin.so and a libjavaplugin_oji.so

    both of which are in the plugins directory already
    rig changes too much
    dual boot: WinXP SP1, Mandrake 9.2

  8. #8
    Join Date
    Dec 2002
    Location
    caves of bedrock
    Posts
    3,129

    Default

    Latest Microsoft Security Updates.
    Last Updated:
    10th MARCH


    If you are a security freak: Use Microsoft Baseline Security Analyzer (NT/2000/XP/2003)
    ======================
    icq : 203189004
    jabber : asklepios20@jabber.org
    =======================
    Linux user since: April 24, 2003 312478
    yabaa dabaa doo...
    Customized for 1024x768

  9. #9
    Join Date
    Jun 2003
    Posts
    135

    Default

    finally! the applet loads! woohoo!

    you guys rock, thanks for all the help :D:D:D
    rig changes too much
    dual boot: WinXP SP1, Mandrake 9.2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •