Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Few questions that have me stumped...




  1. #1

    Default

    Ok...welllllllll...

    I've just dualed Slackware 8.1 on my main box hoping that i can get games etc running alright...and then I'll switch over to Slackware 8.1 full time :) byebye winblows!:D

    problems so far:
    I have a USB Microsoft Intelli Optical mouse plugged into the PS/2 port with the adapter. to configure X i went: xfree86setup and followed the instructions. Then i went startx and after about 4 seconds of a blank screen it throws me back to the cmd prompt with errors of:
    /dev/mouse
    Device does not exist.

    so i tried changing the config file located at /etc/X11/XF86config from /dev/mouse to /dev/usb/mouse and /dev/input/mouse etc, but none seemed to work.

    When i installed XP i think i may have selected and said that the mouse was on the USB port forgetting i was using the PS/2 adapter. Maybe thats the problem? Well, i don't have a clue how to change it back to what it really is tho...

    Any idea's on how to maybe install the mouse again, and where the device will be located (/dev/???).


    Another prob:
    Nobody seems to have replied to this prob over @ OCAU (they have, thats how the DNS for the WWW was fixed...but not for the network), so I'm comin back to the experts here hoping to get some responses :)

    I've been playing around with slackware on another box here, just to get the feel of it etc. When i go ping gardiner_desk (my box) it says "Host not found" but when i add 192.168.0.200 gardiner_desk to /etc/resolv.conf it finds it then. I _was_ having the problem of pinging www.google.com and all other sites too but just added my DNS server into one of the config files (can't remember which), but that bit works now. It's just for the network that im having problems with now. I don't want to have to add every computer name and their ips to /etc/resolv.conf otherwise ill be fairly screwed over at LANs :(

    Edit: for the mouse prob i found this page and are trying some things (changing the Option "Protocol" "Auto" type of thing...which would slackware use? I'm trying a fair few of them...but do you think this would actually stop X from even detecting there is a device at /dev/mouse?...i think that /dev/mouse isn't the right device but i don't know why it isn't!)
    At the request of wiggo ;)

  2. #2

    Default

    W00000000000T! i got it going with the following configs in /etc/X11/XF86config

    Section "InputDevice"
    Identified "Mouse0"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    End Section


    by my wheel mouse and back and forward buttons aren't working yet but i have ideas on how to get them to work from a few pages ive read:

    Option "ZAxisMapping" "4 5"
    or
    Option "ZAxisMapping" "X"
    Option "ZAxisMapping" "Y"
    Option "ZAxisMapping" "N1 N2"
    Option "Buttons" "5"


    I can't seem to find where i can set the resolution in X. Im running KDE...

    Also, is there a way to make the mouse smoother? i like having it set fairly high, but when you move it in linux it jumps from point to point and moves faster sometimes than others etc. Would setting this from the link above do anything?:

    The following option will set the mouse device resolution to N counts per inch, if possible:


    Option "Resolution" "N"
    At the request of wiggo ;)

  3. #3
    Join Date
    Nov 2001
    Posts
    381

    Default

    Ooh, I know how to set the resolution in X. First logout of X back to a command prompt, then edit /etc/X11/XF86config
    Someone (Bern) tell me if I'm wrong, but I believe you have to be root also.

    Under the section "Screen" you'll see something like this:

    Section "Screen"
    Driver "SVGA"
    Device "My Monitor"
    Monitor "Generic Multisync"
    DefaultColorDepth 24

    SubSection "Display"
    Depth 24
    Modes "1024x480"
    EndSubSection

    SubSection "Display"
    Depth 16
    Modes "1024x768" "640x480" "800x600" "1280x1024"
    EndSubSection
    EndSection

    Whatcha do is look at DefaultColorDepth, take the value. In this case 24. Then look below under Depth (the one that says24) and right there is the resolution. If it shows more than one under modes (like in my example under 16), it's supposed to use the first one. But I havn't seen that work, so make it look like 24 in the example 24 with what resoluition you want.

    Hope this helps, Later

  4. #4

    Default

    SubSection "Display"
    Depth 24
    Modes "1280x1024"
    EndSubSection


    that got her goin :D:D:D


    still have the ping network box's by their names prob...

    i haven't got the scroll going, or the forward an back buttons...and tips before i try some more things?
    At the request of wiggo ;)

  5. #5
    Join Date
    Nov 2001
    Posts
    381

    Default

    Quote Originally Posted by Grim Reaper
    still have the ping network box's by their names prob...
    For that problem try this, edit /etc/resolve.conf
    make sure it has lines such as:

    nameserver 216.251.32.100
    nameserver 216.251.32.101

    of course you would replace those IP's with those of your DNS servers for your ISP or network.

    The problem is that your ISP's DNS servers won't resolve host names for computers on your internal network. Because the IP's are 192.168.x.x addresses, your ISP couldn't possibly have those in their DNS servers. Plus the computer names you are using are netbios names (i know that because the one you listed wasn't a fully qualified domain name) See if you can get your linux box to use netbios names cause it seems you're on a windows network.

    I think you may have to install Samba, I'll check though.

    edit: yeah, I believe that's right. Check out this link.
    http://www.2000trainers.com/linux/co...x/linux-7.html

    That's kind of RedHat oriented, what with the rpm's. You should be able to get Samba from www.samba.org

    If you get the scroll working, plz post here how you did it. I wanna get my scroll mouse working. If I find it, I'll post it here.

    Later

  6. #6
    Join Date
    Nov 2001
    Posts
    381

    Default

    I got my scroll mouse working. Previously, like you, I had this in my /etc/X11/XF86config:

    Section "InputDevice"
    Identified "Mouse0"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    End Section

    All I had to do is change the Protocol to imps/2
    and add an option section that looks like:

    Option "ZAxisMapping" "4 5"

    and it works for most applications, konqueror, mozilla, even Quake 3. But for the ones it doesn't work on, I had to install imwheel.

    Later

    edit: i have a regular 2 button Intellimouse Optical. With the scroll wheel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •