Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Got Slack




  1. #1

    Default

    Ok, i've taken the plunge and decided to install slackware 8.1 on my main box on the secondary hdd..

    i440bx mobo
    dec21143 nic

    etc

    it has its own 4gb partition and a 200mb swap file

    now

    for some reason while my ps/2 intellimouse optical works in frame buffer console,
    whenever i

    startx as either a user or root
    the mouse plays up, it goes to top right corner and stays there... now sometimes it will work but this ****s me
    also how does one specify in slackware what res to use Xf86 in, its decided to default to 1920x1440.. which i dont like

    60hz

    and also how does one change the refresh rate of the frame buffer console - its 1024x768 so id prefer if it ran at 120hz rather than the 60 its sitting on

    i have a philips 107p10 and gf3 so res and refreshes etc are easy done

    also, i tried to compile myt own kernel from the 2.4.5 development kernal and for some reason the NIC stopped working, effectively halting boot due to not being able to access DHCP

    even tho i compiled the dec2x14x support into the kernel and im pretty sure thats the module it is using as 2.2.9 or wahterver the current default kernel is...

    also, how does one go about installing the nvidia drivers for linux, and where are they located, i might buy q3a and try get that going as my first project

    also major problem IS

    the 80gb hdd with most of my data is on a hpt370 controller which isnt supported, how do i add the linux drivers for it, get them going and where do i get them from? the drive isnt actually raided im just using tyhe controller like another ide controller so i can get ata100 from the board.

    and

    sblive... for some reason i cant get sound... suggestions?
    SileNceR, Messenger of the Dark and the Night. To post quality, or not to post at all, THAT is the Question - Never again ask what can my post count do for me besides increasing my ego, but instead ask what can I do to help someone else!
    Overclockers Melbourne (http://www.ocmelbourne.com).

  2. #2
    Join Date
    Nov 2001
    Location
    Brisvegas
    Posts
    832

    Default

    Originally posted by SileNceR
    [B]for some reason while my ps/2 intellimouse optical works in frame buffer console, whenever i startx as either a user or root the mouse plays up, it goes to top right corner and stays there... now sometimes it will work but this ****s me
    I had a similar problem, first you need to edit the pointer section of /etc/X11/Xf86Config, here's mine (five button optical mouse with wheel,
    [code:1:2f6eedb9bb]
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    [/code:1:2f6eedb9bb]
    Also I had to disable gpm as well. Just chmod /etc/rc.d/rc.gpm to remove the -x or uninstall it with "pkgtool" as root.
    [b]
    also how does one specify in slackware what res to use Xf86 in, its decided to default to 1920x1440.. which i dont like
    Again an edit of /etc/X11/XF86Config, in the "screen section". This is mine,
    [code:1:2f6eedb9bb]
    Section "Screen"
    Identifier "Screen 1"
    Device "NVIDIA GeForce"
    Monitor "My Monitor"
    DefaultDepth 24

    Subsection "Display"
    Depth 8
    Modes "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    Subsection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    Subsection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    ViewPort 0 0
    EndSubsection
    EndSection
    [/code:1:2f6eedb9bb]
    Default depth 24 = 32 million colors, Modes are read from left to right so edit yours so your prefered mode is first. The refresh is set by the monitor settings in the same file, edit this using the info in your monitor manual and X will automagickly use the best rate for your res.
    [b]
    and also how does one change the refresh rate of the frame buffer console - its 1024x768 so id prefer if it ran at 120hz rather than the 60 its sitting on
    You don't have many options for this (afaik) as the fb console is still a work in progress.
    [b]
    also, i tried to compile my own kernel from the 2.4.5 development kernal and for some reason the NIC stopped working, effectively halting boot due to not being able to access DHCP, even tho i compiled the dec2x14x support into the kernel and im pretty sure thats the module it is using as 2.2.9 or wahterver the current default kernel is...
    Do "uname -a" to see what kernel you have installed, you can do a slack install with a 2.4.5 kernel by typing "bare245.i" at the initial boot prompt when installing.
    [b]
    also, how does one go about installing the nvidia drivers for linux, and where are they located, i might buy q3a and try get that going as my first project
    The README file at nvidia has comprehensive instructions and this might be a good subject for a seperate thread.
    [b]
    also major problem IS
    the 80gb hdd with most of my data is on a hpt370 controller which isnt supported, how do i add the linux drivers for it, get them going and where do i get them from? the drive isnt actually raided im just using tyhe controller like another ide controller so i can get ata100 from the board.
    Never used one but a google/linux search should provide some info.
    [b]
    and
    sblive... for some reason i cant get sound... suggestions?
    The live uses the emu10k1 module, try "modprobe emu10k1" as root.

  3. #3

    Default

    thanks man, i'll try all that tomorrow when I get up, i need my music right at the moment :)... hrmm actually...

    might try it in 20 mins :)
    SileNceR, Messenger of the Dark and the Night. To post quality, or not to post at all, THAT is the Question - Never again ask what can my post count do for me besides increasing my ego, but instead ask what can I do to help someone else!
    Overclockers Melbourne (http://www.ocmelbourne.com).

  4. #4
    Join Date
    Nov 2001
    Location
    Brisvegas
    Posts
    832

    Default

    got slack yet?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •