Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: [ASRock Z77 Extreme 4] New system build, no display, three long beeps




  1. #1
    Join Date
    Oct 2012
    Location
    Croatia
    Posts
    1

    Question [ASRock Z77 Extreme 4] New system build, no display, three long beeps

    Greetings,

    I have just rebuilded my system, everything is connected properly, all fans are spinning and all lights are working but when I try to boot I get no display and three long beeps from mobo speaker. I used mobo manual and google to find out that it is the RAM issue. I have tried all memory slots in every possible combinatios - but no changes. I have tried another memory but situation remains the same. Any ideas or suggestions?

    My memory is: Corsair Vengeance 2X4 GB 1600 MHz red (I have also tried Kingmax 2X4 GB 1333 MHz)

    Other specs:
    CPU: Intel i5 3570k
    PSU: Corsair TX 850
    GPU: Gigabyte HD 7970 OC

    Thank you in advance.

  2. #2
    dJabba's Avatar
    dJabba is offline Member
    Join Date
    Sep 2010
    Location
    Denmark
    Posts
    295

    Default Re: [ASRock Z77 Extreme 4] New system build, no display, three long beeps

    if it runs on default error codes its a keyboard problem (usual). Some bios however its RAM related ... and again might be different. Don't know your board or bios, but maybe it gives a hint in the direction.
    My advice - never visit a short-url, no matter who gives it to you. You can't trust any source at any time when you don't know your target
    Whitey: ROG Crosshair V Formula/Thunderbolt, AMD 1090T @ 3.2GHz w. NZXT Havic 140, Corsair XMS3 1333 8GB kit, HIS IceQ X HD 6870, Corsair Force GT 120GB, OCZ Vertex4 256GB, Kingston SSDNow 16GB, Samsung 500GB 3" in casedock when needed, Chieftec Nitro88+ 650W, NZXT H2 White, 3x Asus VS248 24"
    Snuggles: Zotac Zbox HD-ID40 (Atom d525, worst purchase ever on cpu), Patriot Pyro 60GB (Thanks to Tweaktown Giveaway), 4GB 800' DDR2 SO-DIMM
    Bcube (NAS): ASUS F1A75-I Deluxe, AMD A6-3500 @ 2.1GHz, LSI 9240-8i (M1015) controller, GSkill Ares 1866 8GB blue kit, 4x Seagate SV35.5 2TB, 1x Seagate Barracuda 1.5TB, 1x Samsung HD103UJ, 1x Samsung F4 2TB, Temp. Rebel9 Alu case, Corsair H60, 2x Icy Dock MB973SP-B, NZXT UI01, Enermax T.B. Silence on docks and cpu, Aurum 500W gold PSU. (Draws 65W average, doesn't peak above 100W at any time)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •