buckchoi -

Have you enable the ASUS version of PAT? I've got the same setup, only your memory numbers are way lower?

In bios, goto the Advanced->Chipset section, and set the "Performance Accel Mode" setting from Auto to Enable. You'll boost memory bandwidth....

Jeff

PS - I'll be curious about stability after you set it, as I'm having some stability issues with the same setup.