Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Mass Effect (steam) bug




  1. #1
    Join Date
    Oct 2003
    Posts
    63

    Default Mass Effect (steam) bug

    I bought Mass effect via Steam a couple of days ago and downloaded.

    When I try to launch the game I get the Mass effect Splash screen followed by a blank screen and the busy mouse pointer which I take to mean that something is loading. But that's followed up by a cryptic error message and a crash back to desktop. Error messages seem to differ slightly each time, below are a couple of examples.





    All drivers are up to date (mobo, GPU, Sound card and even the bios). Am running XP pro 32 bit. SP3.

    What I have tried so far
    -Deleting local content and redownloading whole game
    -Verifying integrity of cache files
    -defragmenting local game files
    -Reinstalling Steam
    -Scannning Hard drive for errors
    -Using a registry cleaner to fix registry errors (CCleaner)


    Would appreciate any further suggestions as I really want to play this game.
    Sandy Bridge Pentium G840
    Asus socket 1155
    Corsair 8GB (2 x 4GB) DDR31866
    PNY geforce 9600gt PCI-E 512Mb
    HP w1907 widescreen LCD
    Creative sound blaster X-Fi Titanium
    Corsair Performance Pro 256GB SSD
    1TB Hitachi Deskstar HDD

  2. #2
    Join Date
    Oct 2003
    Posts
    63

    Default Re: Mass Effect (steam) bug

    Fixed by rolling back to forceware 175.19. Apparently lot's of people have to do that to play Mass Effect.

    How do we inform Nvidia about this so they can fix it in their next release?
    Sandy Bridge Pentium G840
    Asus socket 1155
    Corsair 8GB (2 x 4GB) DDR31866
    PNY geforce 9600gt PCI-E 512Mb
    HP w1907 widescreen LCD
    Creative sound blaster X-Fi Titanium
    Corsair Performance Pro 256GB SSD
    1TB Hitachi Deskstar HDD

  3. #3
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default Re: Mass Effect (steam) bug

    Thanks for posting your fix. This isn't the first time that a driver has caused issues with a game, and I wouldn't be surprised to see nVidia come out with a patch for the driver.
    Old age and treachery will overcome youth and skill
    My Toys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •