Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Master/Slave Settings




  1. #1

    Default Master/Slave Settings

    Hi,

    I have a RunCore Pro 70mm SATA Mini PCI-e PCIe SSD with 64GB and use it as replacement for the slow original SSD of an EeePC 901 GO. The disk works fine, however it appears as slave not as master. The 901 GO has only one disk, so the BIOS complains at bootup that there's no master present.

    Is it possible to fix this somehow (e.g. force the disk to appear as master) by changing some jumpers on the disk. Soldering (and thus voiding the warranty) wouldn't be a problem for me...

    Thanks
    groovingandi

  2. #2

    Default Re: Master/Slave Settings

    Update: Using BootBooster, the EeePC boots without complaining about the missing master driver (so you don't have to press F1 to continue).

    Anyway, it would be interesting to know how to modify the drive to force it to master.

  3. #3
    Join Date
    Apr 2009
    Location
    NY
    Posts
    160

    Default Re: Master/Slave Settings

    Actually we have been suggesting taking the original SSD right out of the machine to avoid this problem.

    Please do a step by step review on how to install Bootboster and change the settings to make the Runcore SSD boot without hitting the F1 key. I am sure many people would be very interested in it.

    I look forward to your review and I will deffinatly toss out a tweat on twitter to promote it for you. Maybe post it here and on eeeuser.com

    Matt Dawson
    Runcore CMO

  4. #4

    Default Re: Master/Slave Settings

    Actually we have been suggesting taking the original SSD right out of the machine to avoid this problem.
    Hm, I don't know what you mean... The original SSD was taken out of the machine of course - the RunCore SSD is the only disk working in my EeePc right now. However, it's identified as "secondary slave". The original disk was installed in the same slot and was identified as "secondary master" - there has to be a difference in the behaviour of the disks somewhere.

    Anyway - here are the simple steps that worked for me on an EeePC 901 Go:

    • Create a primary partition (size 8MB) at the beginning of the disk - obviously this is best done before installing your operating system. Note: I don't know if it really has to be a primary partition and I don't know if it has to be at the beginning of the disk - but that's what worked for me.
    • Install the OS and ignore the reserved BootBooster partition - we'll take care about it later. Just make sure the OS doesn't use the space.
    • Change the partition type of the BootBooster partition to type 0xEF (EFI FAT-12/16). Under Linux, this can be done with fdisk - under Windows it's probably tricky to find a program which is able to do it. It's only a "set once"-action, so you can always use a Linux live-cd to change it and keep using Windows.
    • Make sure, the BootBooster option is enabled in BIOS.
    • Reboot! Note: the first reboot will be an ordinary (slow) reboot to fill the partition with the necessary data for the quick boot - afterwards it should skip quite some parts of the booting process, including the F1-message


    I haven't tested this with Windows, only with Ubuntu, but I can't imagine any reason why this should depend on the OS. Anyway, some confirmation from Windows users would be nice.

  5. #5
    Join Date
    Jun 2009
    Posts
    20

    Default Re: Master/Slave Settings

    SATA hasnot the concept of master and slave.
    Update the BIOS and try
    RunCore may need to do a 50mm sata one

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •