Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 28 12311 ... LastLast
Results 1 to 10 of 272

Thread: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*




  1. #1
    Join Date
    Aug 2009
    Posts
    27

    Default MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *SOLVED*

    *** EDITED ON 6-10-2009 ***:

    For 'first-time-readers' of this thread: RunCore has solved the problem with an newly designed drive... Check from page 14 and futher for details on that...

    *** END EDIT****


    Just a few days ago I recieved the long awaited RunCore 1.8" SSD.

    So I instantly, I had to put the new drive in my Macbook Air (Rev. A)!

    I Did, but the result is that it isn't working at all sofar.

    This is the deal:

    - The SSD drive works fine when in it's enclosure connected via USB.
    - When I put the original PATA-HD (form the MBA) in the enclosure it also works fine.. (which imo proofs the zif-pen-setting is fine).
    - When I connect the SSD to the MBA Zif Cable it just doesn't work.
    I use the Leopard instal-disc (via an external usb-dvd-drive) to boot to Leopard-installation in which I can use Disc-utility to check the drive's (and there is no sign at all of the PATA SSD drive sadly)...

    I even tried to put an extra thin layer on the original air's ZIF-cable, for some extra strenght, but without succes.

    Because I tried to connect in many differant ways, my original MBA ZIF Cable is now almost broken, so I already ordered a new cable and stopped testing with the RunCore drive. But this is ofcourse not the way I hopped it should go...

    I can't believe RunCore ships this drive with a label "Solid State Drive for Macbook Air Rev A" without having tested it on a MBA Rev. A, so what could be the problem?

    Are there any succes story's of users with this drive and a MBA Rev. A??
    Anyone got an idea perhaps?
    Last edited by Martijn; 10-06-2009 at 04:08 PM.

  2. #2
    Join Date
    Apr 2009
    Location
    NY
    Posts
    160

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    What format is the drive in?

    Did you use Carbon Copy Cloner to clone your original HDD?

    Matt

  3. #3
    Join Date
    Aug 2009
    Posts
    27

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    Hi Matt,

    The drive come's preformated on OSX HFS+ format, with 2 files on it (CCC indeed). I Didn't use that program because i don't want to clone my current drive to the SSD. I prefer a fresh new install of Leopard.

    Because of that, I boot the MBA (with the SSD-drive connected via ZIF) from the original Leopard DVD. After a few moments I can open the 'Disc Utility' in Leopard installation and then I see no HD at all (only the connected DVD-drive).

    When I connect the SSD-drive via the enclosure to another Mac (USB), I can perfectly see the drive. I already repartioned the drive that way (GUID) en reformatted it (HFS+) but the disc stays 'unseen' when connected via ZIF to the MBA.

    By cloning my current drive to the SSD the problem most certainly won't be solved, since the MBA clearly does not see the drive (even an unpartioned/unformated drive would be visible in Leopard Disc Utility)

    Or do you thing different?

  4. #4
    Join Date
    Jul 2009
    Location
    France
    Posts
    57

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    Similar problem here.

    I got the drive excahnged by an Apple maintenance technician, and rebooted with the original drive in the USB case. Ok very Happy the drive is seen and formats well (As originally it is not a bootable format >> Needs GUID).

    So I switch the computer off and go back home to install a brand new OS X.

    When I boot again the drive doesn't show up.

    I went back to the Apple maintenance center, and the guy tries again nothing shows up, so he puts back the Original drive and I head back to the office planning to ask for a replacement of the Runcore drive.

    For whatever silly reason I give it a Last chance and install the Runcore drive in the USB case and there it mounts immediately.

    So I drive a third time to the Apple Maintenance guy and we try another installation.
    Same as yesterday, the drive mounts perfectly, then we switch of, reboot and never shows up again.
    We tried with a different ZIF cable from another MBA rev A, No way
    We tried in another MBA Rev A, No way,
    We re install the original drive and the MBA boots insntantaneously.
    We put the runcore drive back in the enclosure and it mounts on the desktop.

    This makes me feeling the drive firmware isn't fully compatible, and I also question if this has been thorougly tested with an MBA Rev A?

    Thanks to answer this ASAP,as this drive seems quite fast for what I have been able to see (erasing a 20Gb archive of 12 000 files took less than a second).

    Regards

    Gilles

  5. #5
    Join Date
    Apr 2009
    Location
    NY
    Posts
    160

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    I will try to get my hands on an MBA Rev A ASAP.

    Could one of you guys try the clone to see if that works?

    I will try to get an answer out to you guys by tomorrow.

    Matt

  6. #6
    Join Date
    Aug 2009
    Posts
    27

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    Hi!

    That's an interesting thought indeed!

    I thought the only possibility was the ZIF-connector but, indeed, it's also possible that the MBA EFI doesn't recognize the SSD as a HD-drive...

    My MBA Rom version is:
    Model: MacBookAir1,1
    Rom: MBA11.00BB.B03
    SMC-version: 1.23f20

  7. #7
    Join Date
    Apr 2009
    Location
    NY
    Posts
    160

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    I found some info. It looks like someone else had the same problem with an Mtron drive.

    Upgrading Rev A 1.6 80g Macbook Air with Mtron mobi3000 SLC 32gb SSD - Mac Forums

    I hope that helps you get it working in the mean time we will need to think of a way to inform people of these hoops you have to go through to get it working and a way to make it so it works without doing all this work.

    Also please still try the clone process if that works then it will make it a lot easier for the novice while more experienced computer users can go with the method explained on MacRumors.

    Matt

  8. #8
    Join Date
    Jul 2009
    Location
    France
    Posts
    57

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    This seems to me not the problem, as if you read my previous post, whenever with a system or not on it the Runcore drive isn't seen at the second boot, after physical installation. It isn't seen in the system Info the ATA line says that no device is connected !!!!!!

    So it is not at the OS level but at the firmware level.

    We tried with two MBA exchanged the Zif cables, and the Samsung SSD drive worked 100% when the Runcore worked only after being removed from USB enclosure, and didn't show up after a reboot.

    I have a feeling about some kind of SSD drive firmware bug that is overriden by the installation in the USB enclosure.

    I will try to make it a bootable drive by doing a new install on it before actually putting the drive physically in the MBA and see the behaviour.

    Regards

    Gilles
    Last edited by GillesB; 08-27-2009 at 11:24 PM.

  9. #9
    Join Date
    Aug 2009
    Posts
    27

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    Hi Matt,

    Thanks for the searching and tips. I've read the entire thread on the Mac Forums, but there's no solution for our problem. The problems mentioned are more about UDMA-7 and performance issues with the MTRON ssd's, but my drive isn't even recognized at all.


    The method descriped on the first page (boot into leopard from AIRniloc) is exactly what I did in te first place (althoud I didn't use an external HD to boot, but just the DVD via an external-DVD-drive, which is exactly the same ofcourse), but the problem is that the 'Disc Utility' from Leopard doesn't 'see' the SSD-Drive, so I can't partition it, i can't format it, heck I can't even select it...

    He write's (Quote): "Then go to disk utility (under utilities menu) and select your MOBI SSD, go to 'partition' and set up as Mac OS extended (journaled) format, then go to option and select GUID partition...oh yeah, and name your HD.."

    That's where the problem is: I Can't select 'MOBI SSD' (or RunCore SSD) because the only thing so there is the DVD-drive, no HD-drive at all...


    What I don't get is this:

    How is it possible I buy a product on which is stated "...For Macbook Air Rev A"? and you tell me you're going to get a MBA Rev A ASAP? Does this mean this product isn't tested before on a MBA Rev A?

    Regards,

    Martijn

  10. #10
    Join Date
    Apr 2009
    Location
    NY
    Posts
    160

    Default Re: MacBook Air Rev A with RunCore 1.8" Pro IV PATA ZIF Drive *ZIF PROBLEMS*

    I assure you we will figure this out and hopefully have a full blown solution by tomorrow.

    In the mean time keep us up to date if you have a breakthrough.

    Matt

Page 1 of 28 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •