Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: runcore RMA




  1. #1
    Join Date
    Sep 2009
    Posts
    52

    Default runcore RMA

    Dear Runcore,

    I sent you an email more than one week ago for getting an RMA for one of your SSD which is not working. As a lot of people did while not receiving any answer(which is my case too!), I am now sending you this message on the forum hoping that you will consider reading the email I sent you an answering it.

    I am an early buyer of your Runcore Pro IV PATA 1.8" SSD (RCP IV P1864 C).
    My model is PN: XXX, SN: XXX.
    I bought it directly from Runcore, on the 15 /09 / 09.

    You advertised it for X40 and X41, and to my surprise, it did not work on X40.
    I complained on your forum, and there were nothing you could do for it.
    (cf http://forums.tweaktown.com/runcore/...ue-screen.html)

    Then, i tried it in an X41, and it worked well, till 2 weeks ago, when windows crashed, then couldnot boot.
    I could save part of the data from the disk, then reformat it and tried to install a new system on it, but the reinstall failed .

    I tried to use it in the usb to ATA enclosure that you provided for the SSD, and it does not work either (i cannot copy anything on the disk anymore), while the enclosure works well with other disks.
    I hence have a broken SSD now, after 1year and a half where it performed well.
    As it is still under warranty, I would like you to replace it by a model that could fit both my X41 and my X40, which was my original plan.

  2. #2
    Join Date
    Sep 2009
    Posts
    52

    Default Re: runcore RMA

    i am happy to have no answer yet... i didnt know it was chinese new year yet...

  3. #3
    Join Date
    Sep 2009
    Posts
    52

    Default Re: runcore RMA

    dear Runcore.

    Xing Nian Kuai le!
    Chinese new year is over now. Can you help me by telling me what i should do? I bought a Runcore SSD directly from Runcore, and you dont answer my email asking for support!

    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •