Wow, I AM a moron. It turned out that the jumper for SATA was disabled on my mobo. I was looking at the wrong jumper. :o