Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Issues with flashing LSI 9211




  1. #1
    Join Date
    Jul 2014
    Location
    Brighton
    Posts
    2

    Unhappy Issues with flashing LSI 9211

    Hello all.

    It's been a stressful day for me - I recently bought a LSI 9211 with a view to cross flashing it to a 9240 as I'd read many similar reports (including some here, which is why I'm posting) of people doing the other way with little trouble - alas, it wasn't to be, which is quite annoying a it was the same price as the 9240, but had its connectors in a more convenient orientation for my case, so I got it solely for that reason! :(

    Long story short, the flash failed as the flash chip I have is only 4MB, and it seems the 9240 requires 8MB. :( So I've tried to get the card back to how it was, but I can't for the life of me get it to flash successfully. I backed up my existing firmware, bios, and sbr.

    My procedure has been generally:
    • megarec -cleanflash 0
    • megarec -writesbr 0 backupsbr.bin
    • [reboot]
    • sas2flash -f backupfw.bin (then -b backupbios.rom, but I gave up trying to get the bios back until I had the firmware working)


    ...it initially succeeds, but then fails at the end with the error about Mfg Page 2 mismatching. If I try flashing the bios, then it also initially succeeds with the flash, but then fails t the end when updating the "version page 3", or similar (as I say, I stopped bothering with it as the fw is more important). Any ideas on how I can flash this back to normal? The card came with firmware P14 IR on it, if that helps any. I've tried using sas2flash's new "-sbr" option, which sounds like it's designed to fix my firmware problem, but it just doesn't seem to work - just fails the same way.
    Last edited by Qwerki; 07-18-2014 at 07:40 PM.

  2. #2
    Join Date
    Jul 2014
    Location
    Brighton
    Posts
    2

    Default Re: Issues with flashing LSI 9211

    Ok. I tried LSI support giving them all the details and they just told me to use sas2flash :/ ...when I told them I (as expected) got the exact same error, they suggested I try the bootable USB they offer. Which is freedos and....sas2flsh. So I get the same error. *sigh*

    There are options on sas2flash that let you upload and download a full image of the entire flash (sas2flash -o -dflash flash.bin firmware.bin to download it to the controller, and sas2flash -uflash flash.bin to upload it to a file). Could anyone with an actual LSI 9211-8i please try grabbing their flash and placing it somewhere I can download it to see if that will reinitialise my NVDATA (which seems to be the problem)?

    LSI just say to RMA the controller, but a) it's brand new (was still sealed) so just needs reflashing correctly, b) I'd like to try and save the hassle and costs of postage back to them, and c) I bought it from a seller in Hong Kong on eBay...so warranties are likely to get somewhat complicated as when I put the serial into LSI's checker Chinese contact details come up. :/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •