Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: How do i change my hard drive from slave to master?




  1. #11
    Join Date
    Dec 2002
    Posts
    4,246

    Default

    Here is how to enable dma from the begining:

    Open the control panel folder (you can get to it from the start menu) and double click on the "System" icon to launch the system applet. There should now be a small window open with seven tabs at the top (General, Computer Name, Hardware, Advanced, ...), click on the "Hardware" tab. Now in the middle of this window, you should see a button with "Device Manager" on it ... click it. Now you should see a long list in the format of windows explorer. About 1/3 the way down the list is an icon with "IDE ATA/ATAPI controllers", click the + nest to it. There should now be 3 new icons below this. Two of them should say "Primary IDE Channel" and "Secondary IDE Channel". Double click primary and then click on the "Advanced Settings" tab on the window that pops up. You should now see two sections, Device 0 and Device 1. Next to where it says "Transfer Mode:" select "DMA if available" for both devices. Your HDD will be device 0 if it is set to master on your primary IDE channel. Click "OK". Also do this for Secondary IDE channel as well. Sorry this is so long, but i didn't want to leave anything out.
    I've gone too far and need to move on!

  2. #12
    Join Date
    Dec 2002
    Location
    Isle of man
    Posts
    1,332

    Default

    Oh i've been looking for that thanx mate.Any other tips to get my hard drive working at tip top performance.Its running better now but it still scores only about 500 on pcmark.Not too good.Any tips will be grately appreciated
    :flames: :devil win

  3. #13
    Join Date
    Dec 2002
    Posts
    4,246

    Default

    It depends. What kind of hard drive to you have: rpms, data transfer type, ext. ? If you have an ata 100/133 hdd and a mobo that supports it, then you will need 80 pin ide cables if you don't have them already. These cables have different color berg connectors (the pieces of plastic that plug into the mobo and devices) on it to distinguish where they are to go (blue for mobo, grey for slave, black for master) and they also have thinner wires as compared to the 40 pin cables. The most important thing to do is to defragment often. I personaly defrag every day, but once a week will do. Make sure you remove power from your computer (disconnect the black cable from your power supply) before you go plugging and unplugging devices inside your computer. Also, discharge any built up esd by touching the bare metal of teh psu.
    I've gone too far and need to move on!

  4. #14
    Join Date
    Feb 2003
    Location
    Finland
    Posts
    452

    Default

    Quote Originally Posted by minibubba
    Here is how to enable dma from the begining:

    Open the control panel folder (you can get to it from the start menu) and double click on the "System" icon to launch the system applet. There should now be a small window open with seven tabs at the top (General, Computer Name, Hardware, Advanced, ...), click on the "Hardware" tab. Now in the middle of this window, you should see a button with "Device Manager" on it ... click it. Now you should see a long list in the format of windows explorer. About 1/3 the way down the list is an icon with "IDE ATA/ATAPI controllers", click the + nest to it. There should now be 3 new icons below this. Two of them should say "Primary IDE Channel" and "Secondary IDE Channel". Double click primary and then click on the "Advanced Settings" tab on the window that pops up. You should now see two sections, Device 0 and Device 1. Next to where it says "Transfer Mode:" select "DMA if available" for both devices. Your HDD will be device 0 if it is set to master on your primary IDE channel. Click "OK". Also do this for Secondary IDE channel as well. Sorry this is so long, but i didn't want to leave anything out.


    I donīt have that option in my Device manager!!! How is this possible? I have wondered that a quite long time now
    :confused:

  5. #15
    Join Date
    Dec 2002
    Posts
    4,246

    Default

    that was for winXP

    what OS are you running?
    I've gone too far and need to move on!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •