Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Empires (Dawn of the modern World)




  1. #11
    Beefy Guest

    Default

    Some people have problems, but I'd just sit it out and see if anything happens. Usually uninstalling the driver installation is enough.

  2. #12
    Join Date
    Nov 2003
    Posts
    4

    Default

    do a search for drivercleaner. that thing works wonders. it removes ALL remnants of anything ATI or invidia among other things. check it out.
    Athlon XP Barton 2500 w/333 FSB @ 12.5X=2.0ghz
    ASUS A7V8X mobo
    512mb Corsiar XMS DDR3200
    Radeon 9700 Pro - Stock
    Soundblaster Live Xgamer
    Cambridge 4.1 speakers.
    Logitech Cordless Elite Keyboard/Mouse
    Microsoft Sidewinder Pro
    Microsoft Strategic Commander
    80gb + 60gb Maxtor HDs

  3. #13
    Join Date
    Sep 2003
    Location
    USA
    Posts
    925

    Default

    Dang, The recently released game called LOTR War of the Ring doesn't work with this card or these drivers:mad: . It can't even display the first screen so I can't do a screen shot.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •