Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Empires (Dawn of the modern World)




  1. #1
    Join Date
    Sep 2003
    Location
    USA
    Posts
    925

    Default

    I think it is impossible to get ATI video cards to work perfectly. I just got use to the new video drivers and now I found a game that they don't work with.
    Tech support for the game says this; (There are known problems with the version 3.8 Catalyst drivers. Going back to the last version (Catalyst 3.7) fixes this problem. You can get these drivers from www.ati.com.):snip: Oh man

  2. #2
    Join Date
    Jul 2002
    Location
    Canberra, Australia
    Posts
    1,158

    Default

    "Impossible to get ATi cards to work properly" Hmmm....seeing that every game I run on my 9800 Pro and 3.8 Catalysts works 100% correctly, I put this down to your system and the way you've set it up. I play a dozen recent games and not a problem in any of them. Ever.

    You've found maybe the first game I've seen which has specific issues with the 3.8 Cats. There are at most a handful of them.

    Spend some time doing a clean install of Windows on your system and TWEAK IT. Alternatively just sell your radeon and get an Nvidia card, because quite frankly I'm tired of seeing your constant whining on this topic.

    Finally, this is a Video Card issue, so I'm moving it to that forum. The game says clearly not to use the 3.8 Cats, so the issue is with your video card and drivers not the game.

  3. #3
    Join Date
    Sep 2003
    Location
    USA
    Posts
    925

    Default

    Quote Originally Posted by PersianImmortal
    "Impossible to get ATi cards to work properly" Hmmm....seeing that every game I run on my 9800 Pro and 3.8 Catalysts works 100% correctly, I put this down to your system and the way you've set it up. I play a dozen recent games and not a problem in any of them. Ever.
    I doubt changing a setting will help with this particular game and I didn't use the word "PROPERLY". I said perfectly.
    Quote Originally Posted by PersianImmortal
    "You've found maybe the first game I've seen which has specific issues with the 3.8 Cats. There are at most a handful of them."
    A handfull is too many in my opinion when it's the fualt of my most expensive P.C. part or the people that develope the software for it. When it affects a recently released popular titled video game its even worse.
    Quote Originally Posted by PersianImmortal
    "Spend some time doing a clean install of Windows on your system and TWEAK IT. Alternatively just sell your radeon and get an Nvidia card, because quite frankly I'm tired of seeing your constant whining on this topic."
    Do you really think a clean install or tweak will help? I think rolling back my video card drivers probably would be the only fix in this situation (atleast for now), and I posted this message in the gaming lounge more as a warning for users of the game in conjuction with the newest ATI Radeon drivers becuase like I said before, it is a popular game right now.
    This is a place for information and I'm just trying to be informative but maybe I should whine down a little on my video card, I thought I've been doing a good job of it lately but the smoke coming out of my ears when stuff like this happens gets the best of me sometimes (Sorry). Any bids on my card are very welcome...:thumb:
    Quote Originally Posted by PersianImmortal
    "Finally, this is a Video Card issue, so I'm moving it to that forum. The game says clearly not to use the 3.8 Cats, so the issue is with your video card and drivers not the game."
    Ofcoarse its a video card issue\problem but will affect users of the game specifically.
    I didn't find that tech information with the game. I wrote Tech support for the game and posted the reply here.

  4. #4
    Join Date
    Jul 2002
    Location
    Canberra, Australia
    Posts
    1,158

    Default

    Quote Originally Posted by Spongebob
    I think it is impossible to get ATI video cards to work perfectly.
    When you start a post with this line then don't expect any sympathy from me. Those sort of generalizations only serve to put people like myself off helping you. It is obviously not impossible, the Radeon cards are the best performance graphics cards available at the moment.

    Being a 9800 Pro user myself I know perfectly well what the problems (or lack thereof) are with these cards - 90% of faults are USER ERROR. If you have not done a clean install of Windows after having a previous nvidia card, if you've continually installed various versions of ATi drivers without doing a clean driver install, if you don't have an optimized Windows setup then yes you will have problems.

    Put your 9800 Pro up to sell on ebay or even the forums here and believe me it will be snapped up for a decent price. Then go and buy an FX card.

    I'm sure that will solve all your problems :rolleyes2

  5. #5
    Join Date
    Nov 2003
    Posts
    4

    Default

    Thank god i found you guys. ive posted this problem on so many forums. I have narrowed it down to a 9700 pro problem too. thats why the 9800 isnt affected. i have also seen a problem with korea, forgotten war. anything above 1024x768 with AA and Anti at full settings causes all color/textures to be lost. ANyone experience this also.
    so what the hell do we do about empires. i really dont want to ride on the 3.7's til then. DO the 3.7's work. i went pre-catalyst and that worked. but i lost alot of GPU points on my aquamark. (but strangely enough gained 1000 CPU points.)
    Thanks and I look forward toposting with you all
    Rob

  6. #6
    Join Date
    Nov 2003
    Posts
    4

    Default

    and in reply to persian's comments. - take into account, i do love ATI
    i have owned this 9700 since my drive was formatted and xp pro was installed. i have also used drivercleaner and cabcleaner to remove all remnants of any previous ATI driver/control panel files. I still get that exact same screen. My card is not overclocked and i will add my system specs to my sig, for now here they are.

    Athlon XP Barton 2500 w/333 FSB @ 12.5X=2.0ghz
    ASUS A7V8X mobo
    512mb Corsiar XMS DDR3200
    Radeon 9700 Pro - Stock
    Soundblaster Live Xgamer
    Cambridge 4.1 speakers.
    Logitech Cordless Elite Keyboard/Mouse
    Microsoft Sidewinder Pro
    Microsoft Strategic Commander
    80gb + 60gb Maxtor HDs

  7. #7
    Join Date
    Sep 2003
    Location
    USA
    Posts
    925

    Default

    Quote Originally Posted by 94transam

    DO the 3.7's work.

    Yep the 3.7 work with the game but I'm not keeping them. I'll play the game on my Geforce system.
    I've also tried the newest of the newest ATI Radeon drivers just released on the 5th of November (vers 6.14.10.6396) with the game and those don't work either. Then to top it off they screws up GTA Vice city to boot. I can't live with that!:scream:


    GTA Vice City screenshoot with the new Radeon drivers and a 9800 non pro card that uses pro drivers.

  8. #8
    Join Date
    Nov 2003
    Posts
    4

    Default

    Just to give you some other feedback. I have Vice City and the 3.9's do not cause that on mine. Sorry bout that. I'll keep you informed if i find any fixes. do the same for me!
    Rob:bounce2:
    Athlon XP Barton 2500 w/333 FSB @ 12.5X=2.0ghz
    ASUS A7V8X mobo
    512mb Corsiar XMS DDR3200
    Radeon 9700 Pro - Stock
    Soundblaster Live Xgamer
    Cambridge 4.1 speakers.
    Logitech Cordless Elite Keyboard/Mouse
    Microsoft Sidewinder Pro
    Microsoft Strategic Commander
    80gb + 60gb Maxtor HDs

  9. #9
    Beefy Guest

    Default

    the 3.8s and 3.9s have been having a lot of issues in some games at the moment. It's safest to use the 3.7s

  10. #10
    Join Date
    Sep 2003
    Location
    USA
    Posts
    925

    Default

    Quote Originally Posted by Beefy
    the 3.8s and 3.9s have been having a lot of issues in some games at the moment. It's safest to use the 3.7s

    Yep, stayed up late last night and reformatted Win XP and then reinstalled just Vice City and DOMW onto my harddrive tried changing every setting back and forth that I could think of (Cmos, games, and Windows) to try and correct the two games above with the new 3.9 drivers. Unfortunatly I hardly had any success . Although I did get Vice City going at a low resolution but I can't live with that, so I took your advice Beefy and went back to the old 3.7 drivers for now. Those 2 games both work fine atleast for now but I still have about 100 GB worth of modern video games left to reinstall on my system again:barf: and who knows what will happen since my game collection has vastly increased since I last used the 3.7 drivers:?: . Wheres the nervous icon when I need it?


    Question for you Beefy
    .... Should I reformat my drive again since I've installed the 3.9 drivers and then went back to the 3.7? I've decided to keep the 3.7's for now. I heard from here and other forums that ATI drivers can have some nasty sideaffects when you install, unistall, the reinstall different drivers. I'd hate to install all my stuff and then find out I should have reformatted my drive account of my video card again.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •