Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Help Needed With Sapphire ATI Radeon X1950 Pro




  1. #1
    Join Date
    Apr 2006
    Posts
    45

    Default Help Needed With Sapphire ATI Radeon X1950 Pro

    Hi all, just got myself a Sapphire X1950 Pro 512MB GDDR3 (AGP) today, but i'm having problems.
    First i had to go get another psu cause there was no word about it needing 450w. Got that and put it in no problems !! The m/c run's fine untill i try anything 3D. Tried 3d mark m/c crashed and rebooted, tried the 3d part of ATI control centre, m/c crashed and rebooted.
    When i say crashed i meen the screen covers in lines going differant colours, but you can still make out the windows screen behind it. But i cannot do anything.
    The card itself has 2 power points on the back of it, both are the same type. At this moment i have only power going into 1 of them as i have not had a card with 2 of the same on before and i dont want to blow this card.
    On the box it came in it has stated on the side *450-watt power supply or greater, 38Amps on 12 volt rail. I have no idea what this means (yes i'm dumb)
    The psu i got is a Trust 570w Pro psu duel fan.

    Any help would be very helpful....Thanks

    System is =
    AMD64 3700+ (754 clawhammer)
    Asus K8V SE Deluxe (K8T800 chipset)
    Artic Freezer Pro
    2 x 1Gb Corsair CMX1024 PC3200 (now PC3600)
    200Gb HD
    Sapphire ATI Radeon X1950 Pro (if it works)
    Creative Sound Card
    AMD64 x2 4400+ @ 2.4Ghz (939)
    Asus A8n-sli Deluxe
    Artic Freezer Pro
    TT Tough power 700W PSU (w0105)
    2 x 1Gb Corsair CMX1024 PC3200
    200Gb HD
    Sapphire HD3870 512Mb


  2. #2
    Join Date
    Sep 2002
    Location
    Central Alberta , Canada
    Posts
    1,019

    Default Re: Help Needed With Sapphire ATI Radeon X1950 Pro

    Find the manual. You prolly need both power plugs hooked up. My guess would be that they use two plugs because they do not want the card drawing all of its' power from a single set of wires. Usually connections such as the one you describe are not put there because they look pretty. Have you uninstalled your old video drivers and installed the latest ones from ATI?
    Antec 900 case (4 120mm and 1 200mm lighted fans + UFO flashing light set + 2 12" and 1 6" Mutant Mods meteor lights) - Aerogate ll thermal controller - Asus M2N-e SLI - AMD 64 X2 AM2 6400+ - Corsair TX650 PSU - MSI 450GTS Cyclone OC - 2 X 2GB Patriot Extreme Performance PC2 6400 RAM - SATA 320 GB Seagate HD, SATA 300GB Maxtor HD and IDE 80 GB Samsung HD - Floppy Drive/Card Reader Combo - LG SuperMulti Lightscribe 18x DVD RW - Plextor PX-716A DVD r/rw - Windows 7 Home Premium 64

    Crude but Effective ... it is a way of life.

  3. #3
    Join Date
    Apr 2006
    Posts
    45

    Default Re: Help Needed With Sapphire ATI Radeon X1950 Pro

    Quote Originally Posted by PrairieDawg View Post
    Find the manual. You prolly need both power plugs hooked up. My guess would be that they use two plugs because they do not want the card drawing all of its' power from a single set of wires. Usually connections such as the one you describe are not put there because they look pretty. Have you uninstalled your old video drivers and installed the latest ones from ATI?

    Hi, thanks for the quick response.
    First the manual aint worth **** !! it does not even show it having 2 points on the back of it. It's more for the PCI version, i think they rushed it out.
    Whats the likely hood of the card blowing if i do that?
    As for the drivers i used the ones that came on the instalation disc, then i got the latest ones from ATI 6.12.

    Thanks

    P.S . I forgot to mention that i use Everest to check my m/c specs, this is not showing that this card is on my m/c. Does this matter?
    Last edited by Madmox; 12-23-2006 at 03:17 AM.
    AMD64 x2 4400+ @ 2.4Ghz (939)
    Asus A8n-sli Deluxe
    Artic Freezer Pro
    TT Tough power 700W PSU (w0105)
    2 x 1Gb Corsair CMX1024 PC3200
    200Gb HD
    Sapphire HD3870 512Mb


  4. #4
    Join Date
    Apr 2006
    Posts
    45

    Default Re: Help Needed With Sapphire ATI Radeon X1950 Pro

    Hi, just to let you's know that you were spot on and that i did connect the other power supply and away i go.

    Thanks for your help

    Just done 3D mark05 and got 9375 for the card only and Aqua mark score of 71,512 . Guess who's happy now
    Last edited by Madmox; 12-23-2006 at 05:32 AM.
    AMD64 x2 4400+ @ 2.4Ghz (939)
    Asus A8n-sli Deluxe
    Artic Freezer Pro
    TT Tough power 700W PSU (w0105)
    2 x 1Gb Corsair CMX1024 PC3200
    200Gb HD
    Sapphire HD3870 512Mb


  5. #5
    Join Date
    Sep 2002
    Location
    Central Alberta , Canada
    Posts
    1,019

    Default Re: Help Needed With Sapphire ATI Radeon X1950 Pro

    Glad you got it fixed!
    Antec 900 case (4 120mm and 1 200mm lighted fans + UFO flashing light set + 2 12" and 1 6" Mutant Mods meteor lights) - Aerogate ll thermal controller - Asus M2N-e SLI - AMD 64 X2 AM2 6400+ - Corsair TX650 PSU - MSI 450GTS Cyclone OC - 2 X 2GB Patriot Extreme Performance PC2 6400 RAM - SATA 320 GB Seagate HD, SATA 300GB Maxtor HD and IDE 80 GB Samsung HD - Floppy Drive/Card Reader Combo - LG SuperMulti Lightscribe 18x DVD RW - Plextor PX-716A DVD r/rw - Windows 7 Home Premium 64

    Crude but Effective ... it is a way of life.

  6. #6

    Default Re: Help Needed With Sapphire ATI Radeon X1950 Pro

    You got the fastest agp card made! congrats!
    My System:
    -AMD Athlon 64 3200+ Manchester Em4 Revision
    -Abit KN8-ULTRA
    -X800GTO2 @ X850XT PE (16 pipelines)
    -1024MB PQI TURBO DDR 400 @ (2x512) Dual Channel
    -450W Heavy Duty Rosewill Powersupply
    -Samsung Syncmaster 940BF>>>NEW
    -Seagate 250GB 16MB cache (perpendicular recording) with NCQ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •