Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Unable to boot normally, Radeon HD 4850




  1. #1
    Join Date
    Feb 2009
    Posts
    43

    Default Unable to boot normally, Radeon HD 4850

    I've been using a Radeon HD 4850 for about 5 months now. Today when I restarted my computer, after the startup screen my screen just turns black. I can still hear my AIM turn on and what not. It does the same when I try to run it on 640x800. I've tried to uninstall the drivers and reinstalling different versions of drivers in safe mode. I've used driver sweeper and CCleaner too.I also tried to clean the inside. I haven't done any OCing when this problem came up. My mobo didn't come with a onboard graphic card but after I uninstall the drivers, I can see the screen after start up. Is my graphic card trashed? Or can someone seriously help me?


    tl:dr? Graphic card doesn't work, How can I fix it?

    Running on Vista Ultimate 32bit.

    SAPPHIRE 100245L Radeon HD 4850
    Thermaltake Purepower W0100RU 500W
    G.SKILL 4GB (2 x 2GB)
    Intel Core 2 Duo E8400
    GIGABYTE GA-EP45-UD3R

  2. #2
    Join Date
    Apr 2004
    Location
    Australia
    Posts
    1,525

    Default Re: Unable to boot normally, Radeon HD 4850

    Your PSU is your problem as it only supplies 15A on the 12v rail & that videocard requires 22-24A by itself so go get yourself a decent PSU that can carry that load.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •