Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 8 of 8

Thread: Leadtek Geforce Ti4200




  1. #1
    Join Date
    Aug 2002
    Location
    Quebec, Canada
    Posts
    1,369

    Default

    http://www.leadtek.com/graphics/a250le/a250le.htm

    what do you guys think of this card ? are leadtek good cards ?

  2. #2
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default

    Check out the new 4-Way Ti4200 Shootout that just posted to TweakTown. It may give you some insight as to what is good and what sucks. :)
    Old age and treachery will overcome youth and skill
    My Toys

  3. #3
    Join Date
    Aug 2002
    Location
    Quebec, Canada
    Posts
    1,369

    Default

    thanx....:thumb:

  4. #4
    Join Date
    Jul 2002
    Posts
    41

    Default

    I bought the 64 MB version of this card (they got 128 MB as well) and I'm very happy with it (even if it is quite heavy due to the huge heatsink :)

    The review mentions there was no DVI => VGA gizmo, but I did get it with mine. Best thing would be to ask before you buy.

    The VIVO part is very impressive, basically it lets you use the PC as a hard drive recorder or dump video tapes to HD. However, what dictates the format/codec you'd be able to you effectively (I mean decent res and full frame rate) is you CPU horse-power.

    There is some guides at www.vcdhelp.com

    If you are planning to use mutli-monitor bit, unless you got 2000/XP running, you won't be able to use span modes, only clone (that's what the manuals recons, I haven't tried it yet).

    As far as performance goes, I only got an Slot A Athlon 770 but all games I tried ran pretty well at 1024x768x32 with AA and Aniscopic filter (unlike MX400 there are a few levels of that). WHat I mean pretty well is FPS of around 60-85 (maybe more but I always got v-sync on). Only time I noticed a drop (to around 30-50) was in QUake 3 when LOTS of gibs etc are flying around, but then again that it a CPU issue.


    The main reason why I got this card was UT2003, but that's been pushed back until end of September (according to official oz distro site). However, the demo/test should be out by the end of this month.

  5. #5
    Join Date
    Nov 2001
    Location
    Texas, USA
    Posts
    4,825

    Default

    I'll enjoy seeing the official demo when it comes out. Probably be a 100+ MB download, but that's OK too. :)

    Though not mentioned in the shootout, the X-Micro board that I use (64MB version) overclocks to 310/610 with stock cooling. ;)
    Old age and treachery will overcome youth and skill
    My Toys

  6. #6
    Join Date
    Nov 2001
    Location
    New England Highlands, Australia
    Posts
    21,907

    Default

    I've got the Leadtek WinFast A250 LE TD - MyVIVO Edition planned for myself very soon. ;)
    <center>:cheers:</center>

  7. #7

    Default

    Yeah i was pretty impressed with the Leadtek card

    Overclocking of the 64MB card wasn't as great as other 64MB cards (due to the use of 4ns ram over 3.8 or 3.6ns)

    But a card is a card.
    Cameron Johnson
    Senior Hardware Reviewer
    TweakTown

  8. #8
    Join Date
    Aug 2002
    Location
    Quebec, Canada
    Posts
    1,369

    Default

    Thanx guys, my friend at work will be picking one up tonight. He asked me if I knew if it was good or not, so I asked you guys...YOU GUYS ARE AWESOME !:thumb:

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •