Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: SVCHOST.exe is running at 50%




  1. #1
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    Hi everyone , just wanted to ask how to make my svchost.exe stop running and hugging up my cpu. It seems to be constantly running at 50% or my CPU cpasity. This happened after I updated my MB drivers, the via 4in1 drivers...... my GeForce 2 started working and my svchost.exe started hugging cpu.....

  2. #2
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    Try restarting DNS client or stopping it.

  3. #3
    Join Date
    Feb 2002
    Posts
    36

    Default

    Well if you want to turn svchost off you could go to
    Control Panel then Adminstrative tools then Services...

    What you will be looking for in the services program is
    "Server" thats what it will be under...

    Supports file, print, and named-pipe sharing over the network for this computer. If this service is stopped, these functions will be unavailable. If this service is disabled, any services that explicitly depend on it will fail to start.

    That there is something to note...

    Alternate way to take care of svchost without shutting it down...
    you could simply hit ctrl alt delete and click Processes tab.

    under that you should see the svchost and a whole ton of processes... just simply turn the svchost prioity down it may help i am not sure...

  4. #4
    Join Date
    Jul 2005
    Posts
    1

    Default Re: SVCHOST.exe is running at 50%

    ok I tried to lower priority but it says access denied, is there any other way of going around it coz my svchost is running at any remaining percentage after every process, what i'm saying is that if all other processes are running at 20% svchost takes the remaining 80% so my system always runs on 100%, when I stop the service the computer says it will shut down it 45 seconds and it does as soon as the time is up

  5. #5
    Join Date
    Nov 2003
    Location
    Minnesota, United States
    Posts
    4,543

    Default Re: SVCHOST.exe is running at 50%

    Svchost is a process used by a number of MS services. In this case, it's the one for Remote Procedure Call, which must be running or else you'll get the shutdown message you described.

    Unfortunately, I've heard of nothing that will cause this to to take up 100% CPU usage. That said, it's not a huge deal because it doesn't have a very high priority so it shouldn't slow down the system much or at all.

    Still, I'd Google around a bit more if I were you to see if this is a common problem.

  6. #6
    Join Date
    Jan 2003
    Location
    80km south of Sydney
    Posts
    4

    Default Re: SVCHOST.exe is running at 50%

    Reformat. Guaranteed to fix the problem. Everything else is bull****. Obviously u have something u can't handle. REFORMAT DUDE! Works everytime.

  7. #7
    Join Date
    Nov 2003
    Location
    Minnesota, United States
    Posts
    4,543

    Default Re: SVCHOST.exe is running at 50%

    That's a really inefficient way to fix minor problems. It also stops you from learning how to prevent them in the first place, which means you'll do the same damn thing again and again and need to continually reformat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •