Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: Can't delete a file in WinXP




  1. #21
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    98

    Default

    Tried all of the listed suggestions except for getting the WinXP tweaking app. Even tried searching the registry and deleting any string that has a reference to the folder. Still no luck.

    I have TweakUI and X-teq Setup for tweaking already. Should I still try this suggested app?
    Owner of the computer "Alatar the Blue"

    Athlon XP FX-53
    MSI NeoPlatinum2
    2 GB Kingston PC 3200 CL2 RAM
    ATI x800 XT
    Creative Labs Audigy 2 ZS
    21" Viewsonic Flat CRT
    Logitech Z-680 speakers
    2 x WD Raptor II
    120 GB Western Digital SE SATA HD
    Windows XP Home SP2

  2. #22
    Join Date
    Dec 2002
    Location
    caves of bedrock
    Posts
    3,129

    Default

    well lets just know what file u r trying to delete and what was it related to?
    it is sounding weird now. :confused:
    Latest Microsoft Security Updates.
    Last Updated:
    10th MARCH


    If you are a security freak: Use Microsoft Baseline Security Analyzer (NT/2000/XP/2003)
    ======================
    icq : 203189004
    jabber : asklepios20@jabber.org
    =======================
    Linux user since: April 24, 2003 312478
    yabaa dabaa doo...
    Customized for 1024x768

  3. #23
    Join Date
    Mar 2003
    Posts
    133

    Default

    Ok, I guess this is the situation:

    He or She used PartitionMagic to merge drive D (for example) into drive C, and PM remapped the drives, so everything "pointing" to drive D was changed, and now is "pointing" the directory (for example "MyDriveD") where is all data of drive D.

    With the mapping the Recycler and the System Restore of the drive D are now in the directory he or she wants to delete.

    I guess the solution is disable both "services". To disable System Restore, press Windows+Break or right click in MyPC->Properties, and go to "Restore System" tab, and tick "Turn off System Restore ". But with this all your previous restore points will be lost. After this (you may need to reboot) you can delete the folder "System Volume Information" in the directory "MyDriveD".

    For the Recycler I'm not sure if you can delete it, but you can try by disabling it. Right click in Recycle Bin->Properties and tick "Don't move files to Recyle Bin....". Now you can try to delete the folder "Recycled" in the directory "MyDriveD".

    If this don't work, is better you forget that directory...or better format the drive. J/K

    Before you try all above, wait and see is someone has a better idea or something to correct.


    P.S. Sorry is some names don't match, but my XP is in Spanish

  4. #24
    Join Date
    Jun 2003
    Posts
    1

    Default

    Man, Service Pack made a directory which I can't erase and it's driving me batty!

    Any ideas?

  5. #25
    Join Date
    Dec 2002
    Location
    caves of bedrock
    Posts
    3,129

    Default

    and wats the name and location of the directory?
    Latest Microsoft Security Updates.
    Last Updated:
    10th MARCH


    If you are a security freak: Use Microsoft Baseline Security Analyzer (NT/2000/XP/2003)
    ======================
    icq : 203189004
    jabber : asklepios20@jabber.org
    =======================
    Linux user since: April 24, 2003 312478
    yabaa dabaa doo...
    Customized for 1024x768

  6. #26
    Join Date
    Apr 2002
    Posts
    3,141

    Default

    Bring up your "command promt" from the "accessories" menu under your "program" menu, then open up your "task manager" and go to the "processes" tab and end the process "explorer.exe"

    When ya done that you can use the command promt to locate the file on the hdd and delete it. This always work. When done just go to the "applications" tab in the Task manager and choose "new task" there ya type "explorer.exe" to launch it again and you're done.. :devil win


  7. #27
    Join Date
    Feb 2003
    Posts
    53

    Default

    Quote Originally Posted by The__tweaker
    Bring up your "command promt" from the "accessories" menu under your "program" menu, then open up your "task manager" and go to the "processes" tab and end the process "explorer.exe"

    When ya done that you can use the command promt to locate the file on the hdd and delete it. This always work. When done just go to the "applications" tab in the Task manager and choose "new task" there ya type "explorer.exe" to launch it again and you're done.. :devil win

    I had this exact same problem...tried The_tweaker's advice and it worked.

    Thanks !!
    It's not important to know all the answers, as long as you know how to contact someone who does.

  8. #28
    Join Date
    Apr 2002
    Posts
    3,141

    Default

    NP


  9. #29
    Join Date
    Oct 2002
    Location
    Michigan
    Posts
    98

    Default

    Didn't work for me, but thanks for the help thus far. It was originally a folder for a beta-version of a game. I put it on its own partition in case it went batty. Once the beta testing was over, I tried to kill it, and recombine my separated partitions.
    Owner of the computer "Alatar the Blue"

    Athlon XP FX-53
    MSI NeoPlatinum2
    2 GB Kingston PC 3200 CL2 RAM
    ATI x800 XT
    Creative Labs Audigy 2 ZS
    21" Viewsonic Flat CRT
    Logitech Z-680 speakers
    2 x WD Raptor II
    120 GB Western Digital SE SATA HD
    Windows XP Home SP2

  10. #30
    Join Date
    Feb 2004
    Posts
    1

    Default

    If anyone is still reading this thread, I had a similar problem and found a solution.

    I copied a directory tree from another PC to a shared folder on my PC, then moved the shared folder to a different location on the same partition. Some, but not all, of the files in the directory tree have the Guest user as their owner. Some, but not all, of these files were only given *read* permissions (to users other than Guest). I could not delete these files/directories even though my account has administrative privileges.

    To gain access to these files, you can do one of the following two things:
    1. a. Logon as the Guest user.
    b. Use the CACLS command from a command prompt to set permissions for the files you want to change/delete:
    > cacls <filename> /E /G <user>:<permission>

    for example:

    > cacls MyFile /E /G MYPC\jdoe:F

    The above command will modify the access control list for the file MyFile, adding full permissions for user jdoe (on the system named MYPC).

    c. Logoff as Guest, and logon as the desired user
    d. Delete (or edit, etc.) the file.

    2. Unfortunately, I couldn't find a recursive command option for the CACLS command. If you have cygwin installed, the following is easier:

    a. % cd <directory>
    b. % chown -R <user> <filename>

    for example:

    % chown -R jdoe .

    The above command will change the owner to jdoe for all files contained in the tree at or below the current directory. The user jdoe will now be able to delete all files in this tree. NOTE: User jdoe must have administrative privileges in order for this to work.

    This is easier because 1) you don't have to logon as the Guest user and 2) you can change the owner for an entire directory tree with a single command. However, you must have cygwin installed.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •