Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: MS IntelliMouse Explorer prob




  1. #1
    Join Date
    Sep 2002
    Posts
    3

    Default

    Hi. I've bought the MS mouse, unpacked, plug it in the USB and ... nothing, the mouse light didn't go up. Tried add new hardware, nothing. Tried a restart nothing. After a second add new hardware it worked. Now when I restart my mice isn't working, have to log on and run add new hardware ... The mouse is connected to the SONY monitor USB hub. Other mice (GENIUS) work OK. Thanks

  2. #2
    Join Date
    Jul 2002
    Posts
    493

    Default

    try plugging the mouse either to usb plug in the back of the computer....or plug in the mouse (using the usb to p/s2 convert) into the normal P/S2 port. See if it will work like that...it might be the hub?:confused:

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •