Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: HomeXP on Windows98 Network, unable to access Win98 shares




  1. #1
    Join Date
    Feb 2002
    Posts
    1

    Default

    I'm setting up a XP Home notebook computer in a Window98 peer to peer network. The network is using TCP/IP, connecting to the Internet via DSL through a Cisco router running DHCP and NAT. I have successfully added the computer to the workgroup and am able to see all computers. I can access shares on the XP Home computer from the Windows98 computers. However, I'm not able to access the shares on the Windows98 computers from the XP Home computer using NetBios names (I receive an authentication error - wrong username password). I am able to access a share on a Windows98 computer from the XP Home computer using the IP address/share.

    Also, I have enabled and disabled, under Properties of the Local Area Connection, Authentication tab, the "Enable network access control using IEEE 802.1X". Which is a tip I got from TechNet. I have also made sure that ICS in not enabled.

    Do you have any ideas?
    Jeff Winter
    Probity Technologies

  2. #2
    Join Date
    Feb 2002
    Posts
    25

    Default

    About the only thing I can think of right now is: Do the windows 98 PCs use "user level access control" for their sharing, or "share level access control"?

  3. #3
    Join Date
    Jan 2002
    Posts
    5

    Default

    Best guess is to enable the guest account on the Windows XP vcomputer enable shares if they are not the default Shared Documents / like printers, etc.

    You could install and use NetBeui that is in the ValueAdd folder / MSFT/ Net / Netbeui and follow the .txt document


  4. #4
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    hmm.. well.. you should create an account on XP that you log on to Windows 98. When win98 tries to find shares on XP or 2000 based system, it is tyring authenticating through XP, so you must have a username and password that you logon to win98, and set a account with that same username and password on XP to share files and printers

  5. #5
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    xp take a long time to find computer of 98 or 2000. log in as administrator at the prompt and don't enter a password but just press enter.
    it should let you in.
    you don't need to install netbeui. tcp/ip should take care of it.

  6. #6

    Default

    basically all you have to do is enable the guest account and check that local security policies, as the guest account may be featured in a few deny access areas...

    there is also a tweak to stop the xp boxen from getting printer and scheduled task lists from networked PCs, that will speed up your network browsing...i think that tip was in one of the guides Os wrote...

    edit: ooers i just re-read the post, and i think its possible you may have some sort of dns setting wrong somewhere that is possibly farking up what xp is looking for...

    it may also be worth looking at running those network setup disks u create for win98 clients...

  7. #7
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    I don't know why you make it so difficult. XP allows you to make a Network Startup Disk which I used on my laptop (Windows 98) and it cleared up all the problems between them.

    I decided to upgrade that computer to later, so i don't know exactly what's different anymore. Good luck.

  8. #8
    Join Date
    Mar 2004
    Posts
    2,910

    Default

    Goy this from a another forum, it worked for me. Hope it can help others

    On the above issue from what I hear and read Netbeui should work with XP, but I had lot of headache and frustration. Plus Microsoft states they discontinued it and will not support it. So here is a different way to get connected. (Works Awesome)
    Fix. (If you want)
    Just found this article on 12/28/01
    Yes, I finally got XP Pro for Christmas on 12/25/01
    Installed it on 12/27/01. First let me explain what I have.
    2 Win95 Client
    2 Win98 Client
    1 Win98 Client upgraded to XP Pro then converted hard drive to NTFS!!!!!!!
    Yes, once I installed XP pro I thought how cool, but to my surprise I found that my XP pro could not see any of the other clients.
    However, all my other clients could see my XP.
    What I use and don't use.
    Microsoft XP does not support NetBeui anymore and yes that is ok to do file and print sharing. Instead of NetBeui you can use the Microsoft IPX protocol to share files and printers. (I learned this a long time ago with the game Heretic it could be played by IPX.) Yes, all Clients need to be changed to IPX instead of NetBeui. However my XP pro could still not see the other clients until on each client I right clicked on the IPX protcol went to properties and and checked the I want to enable Netbios over IPX/SPX. This will add a new protocol to your clients called Netbios support for IPX/SPX. As for the XP Pro you will need to have the two protcols added
    1. NWLINK Bios
    2. NWLINK IPX/SPX/NETBIOS COMPATIBLE.
    For security this is great. Because it needs to be bound to Microsoft Client where the TCPIP does not get bound to the Microsoft Clients. Helping prevent security issues.
    Once I enabled the Netbios over IPX/SPX on every client connected to the workgroup my XP Pro computer could see all clients.
    I hope this helps.
    If anyone uses or wants help with the following information I would be glad to help or just hear how your xp experiences go.
    Best of Luck!!!!!!!
    Dan Schuessler
    mavericc@swbell.net

  9. #9
    Join Date
    Mar 2002
    Posts
    18

    Default

    You can get winxp to see all win98 systems by just using the network wizards.

    Also make sure your workgroups are set correctly.

    Personally I haven't used netbeui since win95.

    Brent Wilkinson
    Laptop Technician
    Brent@pclaptops.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •